General

help with scanner

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #8197
    Joseph, K9JOE
    Participant

    I have a friend with an old Radio Shack Pro-2050 scanner which has suddenly developed a problem of making a screeching noise while scanning. If it stops on a channel, it seems to be fine, but it is no longer quiet while scanning. Any ideas of what the problem is? And more importantly, any ideas of how to fix? He’s opened it up and found no obvious part failures.

    #9161
    Mike, KJ6VCP
    Participant

    Scanners tend to fail in weird ways, but most models seem to have consistent failure patterns.

    That radio is made by uniden http://wiki.radioreference.com/index.php/Pro-2050

    There are a few similar models, and it looks like there’s a forum at http://rsproscanners.proboards.com/ Try searching the forum for similar cases, and odds are you you will have a few leads on what to try next. It sounds like the radio isn’t being squelched during scan, but that’s just a guess on my part.

    #9162
    Joseph, K9JOE
    Participant

    Good info. I’ll check it out. And yes, it does seem to be a squelch failure. I asked if the squelch works properly when listening to just one channel rather than scanning, and the answer was no. So the squelch is not working. I have found the service manual for it and might try doing some tests on the relevant circuits.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.